Výpis systémových zpráv

Test prostředí

Pro test javy klikněte zde
Po provedení testu prostředí si vyzkoušejte čvičně vytvořit a odeslat testovací elektronickou nabídku.

Probíhá test prostředí

Test by měl skončit maximálně do 60 vteřin. Pokud trvá déle, nemáte buď nainstalovanou javu, nebo ji prohlížeč nemůže použít - detaily naleznete níže.

Výsledek testu prostředí

Vaše prostředí neodpovídá požadavkům pro práci s Portálem, nebo se nepodařilo detekovat některé jeho komponenty. Níže jsou uvedeny nalezené neshody a postupy, jak je odstranit.
Váš prohlížeč je připraven k práci s Portálem. Nyní ještě zbývá ověřit funkčnost vašeho elektronického podpisu cvičným odesláním elektronické nabídky.
Některé komponenty nelze ověřit. Je možné, že systém bude fungovat správně. Ale tato konfigurace nebyla testována.

Java - povolení v prohlížeči

Spouštění běhového prostředí javy musí být v prohlížeči povoleno.

Jak postupovat

  • Mozilla Firefox - menu Nástroje -> Správce doplňků -> sekce Zásuvné moduly -> u položky Java(TM) musí být zobrazeno tlačítko „Zakázat“, tzn. že Java je povolena
  • Opera – Nástroje -> Pokročilé -> Zásuvné moduly -> u položek Java musí být zobrazeno „Zakázat“, tzn. že daná položka je povolena
  • Chrome - menu Možnosti -> karta Pod pokličkou -> Ochrana osobních údajů - tlačítko Nastavení obsahu -> sekce Pluginy -> odkaz Deaktivovat jednotlivé pluginy -> položka Java nesmí být zašedlá a musí být u ní odkaz Deaktivovat, tzn. že Java je povolena
  • Internet Explorer - menu Nástroje -> Možnosti Internetu -> karta Upřesnit -> u položky Java (Sun) musí být zaškrtnuto Use JRE; dále karta Zabezpečení -> tlačítko Vlastní úroveň -> sekce Skriptování -> položka Skriptování apletů v Jazyce Java -> Povolit

Java - verze v prohlížeči

Pro práci s elektronickým podpisem je nezbytné mít v systému nainstalovánu Javu od Oracle, dříve Sun Microsystems, minimálně ve verzi 1.7, doporučená verze 1.8, a prohlížeč musí umět spustit běhové prostředí Javy a v něm pak podepisovací java applet Signer.
Tento test nelze provést, pokud nemáte v prohlížeči povolen javascript nebo pokud nemáte v prohlížeči nainstalované rozšíření pro Javu.

Jak postupovat

Javu si můžete volně stáhnout ze stránek www.java.com, k instalaci budete pravděpodobně potřebovat administrátorská oprávnění v závislosti na typu a nastavení vašeho operačního systému.

Zda a jakou verzi Javy máme nainstalovánu v systému, resp. jakou využívá váš prohlížeč zjistíte v našem testu nebo přímo na stránkách Javy.

Detekovaná verze javy

Vydavatel:
Verze:

Javascript

Aby se stránky, zejména formuláře, mohly aktivně přizpůsobovat volbám uživatele, musí být v prohlížeči povolen javascript.

Jak postupovat

  • Mozilla Firefox - menu Nástroje -> Možnosti -> sekce Obsah -> volba Povolit JavaScript
  • Opera - menu Nástroje -> Nastavení -> karta Pokročilé volby -> sekce Obsah -> volba Povolit JavaScript
  • Chrome - menu Možnosti -> karta Pod pokličkou -> Ochrana osobních údajů - tlačítko Nastavení obsahu -> sekce Javascript -> Povolit
  • Internet Explorer - menu Nástroje -> Možnosti Internetu -> karta Zabezpečení -> tlačítko Vlastní úroveň -> sekce Skriptování -> položka Aktivní skriptování -> Povolit

Operační systém

Portál pro svoji bezproblémovou funkčnost vyžaduje operační systém, který podporuje hashovací funkce SHA-2.

Podporované operační systémy:

  • Microsoft Windows - minimálně verze XP s nainstalovaným Service Pack 3; důvodem je potřeba novějších kryptografických knihoven podporujících hashovací funkce SHA-2
  • Linux - jakákoli moderní verze obsahující openssl knihovny ve verzi podporující SHA-2; tento požadavek splňují všechny běžné Linuxové distribuce vydané od roku 2007
  • Mac OS X - verze 10.5 a novější
  • Není vyloučeno použití jiných OS, Portál v nich však nebyl testován

Detekovaný operační systém

Platforma:
Název:
Verze:

Internetový prohlížeč

Systém může být používán na řadě běžně rozšířených prohlížečů.

Podporované prohlížeče

  • Firefox 3.6 a novější
  • Internet Explorer 10 a novější
  • Opera 12.02 a novější
  • Chrome / Chromium 7 a novější (s java applety jen do verze 44)
  • Safari 6.0 a novější
  • Není vyloučeno použití jiných prohlížečů, Portál v nich však nebyl testován

Detekovaný prohlížeč

Název:
Verze:

Cookies

Váš prohlížeč musí podporovat cookies a jejich ukládání musí být v prohlížeči povoleno.

Jak postupovat

  • Mozilla Firefox - menu Nástroje -> Možnosti -> sekce Soukromí -> Nastavení historie -> Pamatovat si historii (zahrnuje mj. i cookies)
  • Opera - menu Nástroje -> Nastavení -> karta Pokročilé volby -> sekce Cookies -> Přijímat cookies
  • Chrome - menu Možnosti -> karta Pod pokličkou -> Ochrana osobních údajů - tlačítko Nastavení obsahu -> sekce Soubory Cookie -> Povolit
  • Internet Explorer - menu Nástroje -> Možnosti Internetu -> karta Osobní údaje -> posuvník maximálně na úrovni Vyšší